500 ошибка после переноса форума с хостинг на VPS

Всё что относится к vBulletin

Moderator: Aleksandr

Avatar
Topic author
Дим M
Администратор
Администратор
Posts: 1319
With us: 7 years 5 months

500 ошибка после переноса форума с хостинг на VPS

Post #1by Дим » 17 Dec 2013, 20:49

500 ошибка после переноса форума с хостинг на VPS
P.S Из личного опыта

Дим wrote:Не факт что здесь будет точно описано устранение вашей ошибки, но будет указан путь где искать причину.

Раньше при переносе форумов с хостинга на VPS, таких проблем. Но когда то и должно было что то подобное произойти. Суть такова: форумные функции работают нормально, но только стоит попробовать открыть любую тему, ни чего не происходит. Просто открывается белый экран и всё. Так как с VPS имею дело недавно, то сначала грешил на бекап БД, переустанавливал не счётное раз. И форум по новой инсталлировал, и просто папки с файлами переносил - ни чего не помогало. Но потом решил искать причину в своём сервере, и пошёл гуглить Apache. В итоге докопался до лога ошибок, который находится в var/log/apache2/error.log, где и нашел примерно такую запись:

[Tue Dec 17 12:04:36 2013] [error] [client 12.34.567.890] PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/var/www/ваш сайт.ru/includes/functions_post_thanks.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/ваш сайт.ru/includes/class_postbit.php(345) : eval()'d code on line 1, referer: http://ваш сайт.ru/forum.php

Красным - я заменил
Синим - это ошибка

Поковырявшись в файлах форума, functions_post_thanks.php я вообще не нашёл. Скопирол из другого форума и вставил в тот где была ошибка. И о чудо - сообщения стали открываться и форум заработал как и ранее на хосте.

Суть такова - нужно смотреть ошибки в Apache.

Ну вот как то так. Если что не ясно - пишите в комментариях.
i love you mxIni Mysql

! ! !


  • Similar Topics
    Replies
    Views
    Last post

Return to “vBulletin”

Who is online

Users browsing this forum: 1 guest